ProgramLanguage/Script/JavaScript/jQuery/DataTables/日本語リファレンス

DataTable.fnVersionCheck(string)

概要

互換性を保証するためにプラグインが使用しているDataTablesのバージョンをチェックします。

 

構文

fnVersionCheck(
    sVersion
)
 

パラメータ

sVersion
型:string
バージョンを指定します。バージョンの形式は"X", "X.Y", "X.Y.Z"です。
 

戻り値

互換性が保証されているバージョンであれば true。それ以外の場合は false

 

解説

パラメータに指定されたバージョンより、DataTablesのバージョンが新しいと true(同一のバージョンも含む)。
ただし、互換性を本当に保証しているのか不明です。

 

方法を次のコード例に示します。

var oTable = $('#example').dataTable();
alert( oTable.fnVersionCheck( '1.9.0' ) );
 

バージョン情報

DataTables 1.9.0

 

参照


トップ   差分 バックアップ リロード   一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2014-07-29 (火) 08:57:56 (1961d)